Up to 4 php versions in DirectAdmin and Custombuild

Version 1.56

Feature
Finished

TESTING With this change, the CustomBuild 2.0 options.conf can support up to 4 php versions, eg: php1_release=7.2 php1_mode=php-fpm php2_release=5.6 php2_mode=php-fpm php3_release=7.0 php3_mode=php-fpm php4_release=7.1 php4_mode=php-fpm No templates changes are needed. The POST to CMD_DOMAIN action=php_selector now supports values upto the number of php verisons installed. So php1_select can be set to 1, 2, or 4. The php2_select can also be set to 0, but the current internal default doesn't show the 2nd php selector.. since most people don't need 2 php versions live at the same time. Any of the 4 versions can be set to php1_select, which is sufficient almost all the time. Be sure to run "./build update" to get the latest version of custombuild. Also updated CMD_CUSTOM_HTTPD to show correct php-fpm select (also defaults to just 1 php now, based on php_version_selector=1) And fixed a bug where "php 7" should have shown up as "php 7.0" in various areas.

Interested to try DirectAdmin? Get a 30-day Free Trial!